ICT Diary

Network、Server系の内容を気まぐれにUPしていく。

Fortigate Static Route (cli)

概要

トポロジ

[RT1].2-----------.1[RT2].1-----------.2[FW]
    |<------------->|   |<------------->|
           NW1                 NW2
      10.0.10.0/24         10.0.20.0/24

構成

  • RT1 (CiscoRT)
    • I/F 0/0: NW1
  • RT2 (CiscoRT)
    • I/F 0/0: NW1
    • I/F 0/1: NW2
  • FW1 (Fortigate)
    • I/F wan: NW2
  • IP情報
    • NW1: 10.0.10.0/24
    • NW2: 10.0.20.0/24

前提設定

RT2 (CiscoRT)

interface GigabitEthernet0/0
 ip address 10.0.10.1 255.255.255.0

interface GigabitEthernet0/1
 ip address 10.0.20.1 255.255.255.0

RT1 (CiscoRT)

interface GigabitEthernet0/0
 ip address 10.0.10.1 255.255.255.0

ip route 10.0.20.0 255.255.255.0 10.0.20.1

FW

config system interface
    edit wan
        set vdom "root"
        set ip 10.0.20.2 255.255.255.0
        set allowaccess ping https ssh http fgfm
        set type physical
        set snmp-index 1
    next
end

Static Route & Default Route

設定

config router static
    edit 1
        set dst 10.0.10.0 255.255.255.0
        set device wan
    next
end

詳細

edit [NO]                                           :[必須]経路管理番号を指定 (優先度ではない)
set dst <[Network] [Subnet] | [Network]/[Prefix]>   :[必須]設定したい経路を指定
set device [I/F]                                    :[必須]登録した経路のネクストホップI/Fの指定
set gateway [HOP]                                   :登録した経路のネクストホップIPの指定
set distance [AD]                                   :AD値の指定
set priority [No]                                   :StaticRoute内でのプライオリティ
set blackhole [FLG]                                 :ブラックホール経路を有効化 (CiscoでいうNull0)

確認

FW # get router info routing-table static
S       10.0.10.0/24 [10/0] via 10.0.20.1, wan